新しくDebianを立ち上げたんだけど…

Posted by tamura on 7th 11月 2013 in コンピュータ

まぁ、PCではなくPogoplugだったり。
うちのPogoplugは箱にはPogo-P25って書いてあるんだけど、本体の裏を見るとPogo-E02になってたり。
メモリも一応256MB乗ってたんで、Debianをインストールしてみた。

ぽにっとブログさんのPogoPlugでDebian Wheezyを使用する(その壱)辺りを参考にして構築したんだけど、一応一発で起動した。

そこまでは良かったんだけどね…

ハマリそその1
apt-getでインストールされるemacsが23.4だったんで、24.3をソースから入れてみた。
ソースダウンロードして展開して…
./configureしたらエラー(>_<)
なんかccがないという。
ちゃんと”apt-get install gcc“したのにぃ
と、ぐぐってみたらlibc6-devもインストールしないといけないのねorz
メインのマシンはScienticic Linuxなんだけど、そんなの入れた記憶なぁい(汗)

で、なんとかbuildはできた。

まぁ。このハマリはかわいい方で…

ハマリその2
mysqlを入れようと思って”apt-get install mysql-server“を行なった。
そしたらインストール途中でハングアップしやがりましたよ。
別のターミナルからsshすると、接続は切られないもののid/pwの入力まで進まないでやんの。

仕方なく電源切ってリブート…
うん、2度と立ち上がらなくなりました。

USBメモリを再フォーマットからやり直す羽目に…

うみゅぅ、先週の土曜から何回フォーマットしたんだろ?
いまだに作業途中でハングアップ&さようならを繰り返してたり。

なにが原因なんですかね?(謎)
ってか正式なPogo-E02ではないからって事ですかね?(P25として買ったし)
どっかに情報ないかしらね?

やっぱり今はなき(なのかな?)OpenPogoしかまともに使えないのかなぁ

2 Responses to “新しくDebianを立ち上げたんだけど…”

  1. ぽにっとブログ管理人です。
    当方のHPをご覧頂き、ありがとうございます。

    我が家では現在、Pogoplug E02(箱はP25でしたが)をLAN内インフラサーバーとして
    使用しており、DHCPやLAMP等が正常に使用できています。
    参考になる部分もあるかと思い、コメントさせて頂きます。

    まず、現在の我が家の環境ですが、Debian Wheezy 3.10.4(Bodhi氏の公開分)を
    使用しています。LAMPについては下記コマンドでインストールしましたが
    問題なく使用できています。
     $ sudo apt-get install php5 php5-mysql mysql-server apache2 libapache2-mod-php5
    sources.listについては、下記を設定しています。元々こうだったのか、
    インストール後に設定したかは忘れてしまいました。
     deb http://ftp.jp.debian.org/debian/ wheezy main contrib non-free
     deb-src http://ftp.jp.debian.org/debian/ wheezy main contrib non-free
     deb http://security.debian.org/ wheezy/updates main contrib non-free
     deb-src http://security.debian.org/ wheezy/updates main contrib non-free
    かなり古いUSBメモリをストレージに使用していますが、起動後に安定しなく
    なった事は当方ではありません。

    また、Debianが正常に動作しないようであれば、ArchLinuxという選択肢も
    あります。パッケージのインストール時に設定をほぼ手動で行う必要が
    あったり、ローリングアップデートのためパッケージが急に不安定に
    なる事が稀にあったりしますが、そういった状況を許容できる使い方で
    あればいじり甲斐のあるディストリです。日本ではあまりメジャーな
    存在ではないので不安な部分もあるかも知れませんが、Pogoplugは
    コミュニティの正式サポート対象なので、興味があれば使用してみる事を
    お薦めします。

    PogoplugでArchLinuxを使用するのであれば、当ブログでもいくらか
    設定情報を公開しています。興味があればご参照下さい。
     http://unizoff.net/blog/category/pogoplug

    以上、参考になれば幸いです。

    • たむら より:

      わざわざコメントありがとうございます。

      どうやら我が家のPogoplugの問題は接続した32GBのUSBに対する書き込みが間に合っていないためのようです。
      こまめにsyncすれば問題なく動いているようなので、しばらくはこの状態で使用を続けます。
      別にScientific Linuxでサーバを立ち上げていますので、実用はあまり考えていないのでまぁいいかなと(^◇^;)

      今後もご指導いただく事もあるやも知れませんが、よろしくお願いします。

Leave a Reply